Back to overview
Resolved

Security Upgrade Maintenance

Jul 12, 2026 at 2:00am UTC  –  Jul 12, 2026 at 4:00am UTC
Affected services
Molar Providers
Molar Patients
Molar Server
Patient Chart
Patient Care
Imaging
mFax
mChat
Secure Messaging
Message Center
Molar Voice

Resolved
Jul 12, 2026 at 4:00am UTC

Maintenance ended

Created
Jul 12, 2026 at 2:00am UTC

We will be performing a security upgrade to our database infrastructure on July 11 starting at 10 PM ET. You may not be able to access Molar for a short period of time. No action needed on your end. Service will resume automatically.